Technology will make your life easier

the bug was very old… not 80s old but maybe 00s? :sweat_smile:


A major part of my job is helping people identify risks to the quality of their products, and this week the answer was “Please don’t use Excel for that”. I offered to lend the product owner my copy of Humble Pi, by Matt Parker, which has an entire chapter on Excel-related cock ups :laughing:


"Heshmati told the student he had used Excel’s autofill function to mend the data. He had marked anywhere from two to four observations before or after the missing values and dragged the selected cells down or up, depending on the case. The program then filled in the blanks. If the new numbers turned negative, Heshmati replaced them with the last positive value Excel had spit out. "


Well, apart from the obvious, it has a QR code and no actual URL. I can’t type a QR code in on my keyboard…

1 Like

One of my projects regularly synchronises local data with a remote API, and one day a colleague pointed out a curious corruption in the local text which, after some head-scratching, we identified as the result of a Korean character coding system getting involved somewhere. A bit more investigation confirmed that the API responses themselves had the encoding we expected, and the data was evidentially being misinterpreted as Korean somewhere earlier in the proceedings, such that the corrupted text was being re-encoded as utf-8 and sent to us. We raised this with the client (who had the contacts for that API), and they told us that they’d seen this themselves on about three prior occasions, and each time had raised it with the API owners and it had been “fixed”, only for it to happen again sometime later. In the end the client asked if we could do something about it at our end, and I figured out a workaround.

Some time later I was chatting with a colleague in another team who happened to have had dealings with that same API, and he told me that he understood the data was maintained as an Excel spreadsheet…

I’m imagining that there’s one particular user whose Excel settings are bad, and that every time that person saves the spreadsheet it breaks the API.


Oh nice, horror stories for breakfast.


They switched from the actual cost-benefit vaccination model to an emergency backup in Excel, because the one member of staff who knew Python had left.


:cold_sweat: ​‍ ​‍ ​‍ ​‍ ​‍ ​‍ ​‍ ​‍ ​‍ ​‍ ​‍

1 Like

I’m meant to be on a remote training course today.

The joining instructions were sent on Friday morning. They involve downloading some software and connecting to a remote server. None of us are able/allowed to do that.

The trainer is in the States so communications have been delayed. Over the weekend he asked us to chase our IT department to open up some ports.

Not sure that’s going to happen, especially not in time for the first session today. Not sure that’s my responsibility as the trainee either.


For proper irony it should be tech security or anti-phishing training.

(Some years ago at work:
Them: we need to audit your servers, run this third-party binary as root.
Me: No.)


I just got an email about a mandated company “security awareness course”.


Coming back after a break I could see that the presenter was unmuted in Google Meet and that the slides were changing but couldn’t hear anything.

Asked in chat whether it was just me and go no response.

Left and rejoined but the same issue. Finally resorted to unplugging my headset and replugging which fixed it.

Ten minutes after my original message the presenter responded verbally with, “yes that’s just you”. :man_facepalming:


Today for reasons I tried to access something on my Health Insurance App. This wanted a new “Ident” App Two Factor. Okay I install that thing and boom it needs me to identify myself by one of two pins.

I check my keepass and see that I have never made an entry for the first. Oops. I message my healthcare provider about the PIN and I am told: “This was sent to you 2 years ago if you don’t have it we need to issue you a new card and btw you need a new ID photo.” Great. I’ve never needed the PIN and once I activated that Ident thing I’ll never need it again. I have no idea though why I didn’t put this in my keepass file along with everything else?

I try the other option, with the PIN for my ID card… this one I noted in my keepass when I got me first eID in 2013 (I know this because I have the original document I was sent when creating the PIN for obscure reasons I found this immediately when looking for it.). Against all expectations the app could read my ID but the PIN was wrong. I called the local Bürgerbüro: “To reset the PIN you need to come in in person.”

Which one is worse: needing a new health insurance card and a new photo or making an appointment at the local Bürgerbüro to reset the eID PIN?

PS: the reasons were so I could access the new Gesundheitsakte to see if the last E-Rezept (digital prescription) I picked up was in there so I could tell my partner who needs his asthma medication where to look for it if they have now signed his request for it or if he needs to call them first because when we went to pick it up on Saturday the medication was not on the card despite them telling me on Friday it would be there the next day. This is an odyssey now lasting almost a week. Supposed to be easier now with digital precriptions, and smoother and quicker… ha ha ha :frowning:


That’s happened to me a couple of times on phone calls, where even after the fact I’ve not been able to find reference to a PIN I’d supposedly set.

Fortunately it’s not been anything too serious that they couldn’t verify me in some other manner.

1 Like

I have an account with a UK bank, with some cash in reserve in case I visit.

After they put my money in a zero interest account during one of the financial crises, I’ve been transferring Christmas gift money and the like from my parents to a savings account. Tried that recently, but now I need a physical debit card to slot into a card reader device to get a code to do any online banking! Good grief, why?

Anyway, unfortunately, my UK address is my dad’s, and I think he mistakenly binned my last couple of debit card replacements thinking they were bank statements (which I cancelled many years ago).

To order a replacement (to his address) of a card I’ve never seen, I need the last 4 digits of the card.

Fortunately, I found a loophole! In the last confirmation step of the cash transfer I can’t do, I have to select a card to generate the code from the card reader, and they display a list of cards to select in the format --****-1234…


Because OTP authentication was Not Invented Here.

The regs requiring sms auth came in a few minths after the big revelations about the terrible security of telco switches meaning that catching someone else’s sms messages is almost trivial.


Just got billed for a month-to-month mobile plan that I cancelled 10 days ago. Speaking to customer support:

“Ah yes we can see that your cancellation request was uncancelled due to technical issues.”



3am is far too early to be getting out of bed. (I have a plane to catch,)


My :heart_eyes: partner found the PIN for my new eID (I got a new eID last year after the move and so the old PIN was of course invalidated). I had put that letter on the paper-todo-stack and promptly forgot about it.

So a day and 4(!!!) apps later… I got all the digital health stuff sorted… and I don’t even need the other lost PIN.

How is anyone supposed to deal with this?


Hey Gang.

I need help.

I’m playing an old school play by post.

The game has a number of star systems. Each system is linked to exactly three other systems, however, it’s not in a uniform grid system.
I’m looking at a way to plot it without lots of crisscrossing space lanes.

Is there a program that could plot the mapping and untangle it?