Mark Zuckerberg's Vassal Glasses

I have recently, and very temporarily, had more money that sense (this requires relatively little money). It’s been a while since I treated myself to anything that didn’t endanger my liver, but I’ve had… well, a 2020 recently, so I decided to cheer myself up with a shiny new Oculus Quest 2 (which was rather cheaper than I was expecting - dangerous when combined with online shopping and craft beer).

Part of the motivation for this was that I had been idly perusing my Steam library for games that I already owned which were compatible with VR, and amidst Subnautica (although Maxnausea might be a better term for playing it wearing Oculus) and Prey: Typhon Hunter (too scared of typhons to considr playing this), up popped Tabletop Simulator.

Holy smokes, I thought to myself through a craft-beery haze. That will be… that will be just like being there! (–> “Add to Basket”). It was fiddly to get working - TTS is a little janky at the best of times, and adding VR to the mix cranked the jank to slightly terrifying levels before I wrestled them back down again - but last week I actually managed to play a game of Jaipur with a friend. So… was it just like being there?

Hmm. Well. Yes and no. There’s nothing quite like that headset for immersion - you really do feel like you’re in another place, and the first thing I noted entering the world of Jaipur was that I seemed to be playing the game whilst hovering forty feet above a huge overgrown wheat field, with a sinister-appearing rusting red tractor some way off in the distance. It felt rather like we’d set up our game in the Chernobyl Exclusion zone. Still… it was definitely somewhere else, and that felt exciting enough to my inner Tron fanboy that I didn’t really care where it was.

The control scheme mapped onto the Oculus hand controllers is perhaps best described as semi-intuitive. Shuffling decks and rolling dice is a matter of picking them up and shaking them (very hard), but drawing cards into your hand is a more tedious odyssey of menu selections, made more difficult by it not being immediatey obvious what you’re supposed to press to get a right click. There is a tutorial for the controls, but it’s possible that I’m getting old because I almost immediately forgot most of them once the game had started.

The lower resolution of the Oculus images is something you don’t notice too much when you’re being wowed by an overhead starship or gigantic whale phallus, but it is an issue when you’re trying to read cards and boards. I cranked up the resolution in game which actually worked pretty well, but as soon as I left TTS and my PC attempted to render other environments in VR it became very excitable and the fan started to make worrying noises so I quickly turned it back down again.

Pressing ALT in standard TTS brings a selected object or card up to the screen so you can read it more easily. This maps to (obviously) pulling the thumbstick down on the Oculus controls in either hand. With my right hand, this worked terrifically, with the card hovering over my wrist, clear and easy to read. When I tried it with my left hand, the card terrifyingly manifested as a giant uber card of doom, still attached to my wrist but filling the entire game room and neatly bisecting my invisible body.

Manipulation of game pieces is… well. Small diamonds appear over your virtual controllers, and pick up whatever they are touching when you squeeze the grip… except that… well, again, maybe I’m getting old or just a bad shot or still have far too much a meatbrain for virtual worlds, but this had a success rate of about 30%. The rest of the time my hand passed soundlessly and painlessly through the object and, usually, the table. The overall experience was akin to being a frustrated phantom with very weak telekinetic powers (basically, Julian from Ghosts).

I eventually got the hang of it and even managed to win the game, flipping the table in victory and forgetting too late how high up I was suspended. Without the table there, I suddenly felt every one of the forty feet I was hovering above the post-Soviet wastleland, and if there’s one thing VR is extremely good at, it’s triggering my paralysing fear of heights. I had to rapidly log and and lie down on my very comforting carpet.

TLDR; it was great. I can’t wait to do it again. Anyone else tried it?


Is it as semi-intuitive as the ones you voluntarily map onto your keyboard for Deep Rock Galactic?

1 Like

I’m assuming this means you are perpetually trouserless?


My remapping make perfect sense when I do it!

Well, yes, but for entirely different reasons.


I’ve not dare tried it. I can only imagine how unwieldy the whole experience is. :grimacing:

I got an Index with my latest stimulus check, tried TTS in VR and the experience was so turbo-janky I abandoned the idea entirely. You say they don’t map well to Oculus controllers…well, they didn’t know what the Index controllers even were… :stuck_out_tongue:

Like the Steam Controller, Index controllers can download pre-made per-application control mappings from users and I did try that way but it was still super unintuitive and being positioned like a giant standing in the middle of the table instead of just having a table in front of me is, uh…one way to do it, I guess.

1 Like

Yes, TTS isn’t the most stable at the best of times. I found when I got used to the Oculus controllers it -almost slightly a bit- felt like being there. I’ll definitely try it again but I’m not sure how practical it is. I think it would feel less strange with other VR players, and I suspect it’s very frustrating to play against a VR player from your keyboard and watch them flap the components around like an expiring fish.

I dare say we shall find out soon enough. (I’m a bit curious now.)

TTS is one of those things where it’s been such a godsend that it exists this past year and I really appreciate a lot of what it’s doing but it’s also such a weird broken pile of jank that I really wish either other hands were at the helm or there was a reasonable alternative in its particular niche. Tabletopia really is a very different approach that I like much less, things like BGA and boiteajeux are cool for what they’re doing but nowhere near as flexible or user-moddable and the game selection is mostly not the stuff I want to play, and the one other one that’s trying to do basically the same thing, Tabletop Playground, is years of development behind in terms of functionality and has roughly 0.01% the mod support.